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Template Pack 1: Books and Manuals

This pack contains nine basic templates for creating long docu-
ments. Although these templates were designed with software and 
hardware manuals in mind, you can easily modify them for use as 
general purpose books, manuals, training guides, or virtually any 
multi-chapter document. Each template folder, if appropriate, 
actually combines several templates together in a book file: TOC, 
chapter, appendix, and index. You'll find each template enhanced 
with powerful paragraph, character, table, and cross-reference for-
mats; color definitions; variables; special sidebars; HTML map-
pings; as well as background graphics and text.

This packet of templates includes the following:

N BkStyle1: This is designed to keep page count down.

N BkStyle2: This template features prominent headings and gen-
erous white space without increasing page count.

N BkStyle3: This is designed for a book that needs to number 
chapters, appendices, illustrations, etc., independently.

N BkStyle4: This template is ideal for laser-printed software man-
uals, training guides, tutorials, and instructional material.

N BkStyle5: This is the same template as BkStyle2, but with run-
ning thumb tabs on recto pages.

N BkStyle6: This is intended for the small manuals that accom-
pany TVs, VCRs, and similar consumer hardware.

N BkStyle 7: This mimics the pre-5.5 FrameMaker manual.

N BkStyle 8: This is the template we used for this digital series.

N BkIntl: This template is meant for instruction sheets or step-by-
step guides where the contents must be in three languages.
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Book Style 1

This two-column chapter template was designed to resemble 
Adobe’s printed documentation. It provides a good design for 
reducing page count because it uses fairly small point sizes and 
minimizes white space.

Designed to
reduce page

count

The design includes templates for a table of contents, chapter, and 
index, all organized within a sample book file. Three preformatted 
tables, a sidebar format, and formats for illustrations with or with-
out anchored captions are all built-in. The two-column format has 
a trim size of 7.5 by 8.4 inches. A drop cap distinguishes the chapter 
template. You’ll also find five cross-reference formats predefined.

Nuts & bolts

The template contains text describing the template’s formats and 
features in detail—and displaying them all in use. Be sure to print 
the chapter template for later reference.

BkStyle1 sports the gamut of expected formats for three levels of 
heads, notes, bulleted lists, and so on. They need no special expla-
nation. Some, such as Chapter.number, clearly hold their purpose 
in their names. Several others merit special mention.

Illo+caption is the format you should apply to a blank paragraph to 
which you anchor a graphic. It’s linked to the Caption paragraph 
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format and is set so that graphic and caption always remain on the 
same page.

Use Numbered.intro to introduce numbered steps. It resets num-
bered steps to 1, so it’s vital to apply it before each unique series of 
numbered steps. Use it for the “to do this” statement before each 
set of steps.

The Query paragraph format lets you insert queries to document 
reviewers in a standard format that is easy to search for and remove 
later when the document moves on to production. There is also a 
Query character format you can use within paragraphs.

Use Typed-in.para to indicate a paragraph the user must type. A 
character format called Typed-in.text does the same for text within 
a paragraph.

The Bulletsymbol, Number, and TipIcon character formats are 
used by other formats. You won’t deal with them unless you need to 
redefine the Bulleted, Numbered, and Tip paragraph formats.

Making it your own

As mentioned, this template uses small point sizes to reduce page 
count. To retain legibility, be sure you use a body font that prints 
well at small point sizes on the printer you’ll be using.

t With this and most of the other templates, be sure to save the 
original file under a new name and then delete the sample text. This 
text demonstrates and describes the template’s formats so you’ll want 
to keep it available.

The Tip paragraph format uses an asterisk as a dingbat instead of a 
character from a symbol or dingbats font, as is usually done. You 
can change this by redefining the TipIcon character format to be 
the desired dingbat font and then replacing the asterisk with the 
appropriate character in the Autonumber Format box of the Tip 
format’s Numbering property in the Paragraph Designer. You 
should also change the Stretch setting of TipIcon back to 100% in 
the format’s Default Font property.
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Book Style 2

BkStyle2 outdents numbering and extends some headings into the 
side-head area for special prominence. These numbers and head-
ings also use spot color so they remain easy to spot and scan 
quickly. BkStyle2 uses a condensed type, which helps to reduce 
page count while still presenting plenty of whitespace. Because of 
the generous use of whitespace, the template is easy on the eye.

Headings
easy to spot

and scan

The design includes templates for a table of contents, chapter, and 
index, all organized within a sample book file. The general look 
incorporates a one-column layout flanked by a side-head area into 
which some headings extend so the reader can easily scan through 
the sections of the finished document to find material of interest. 
The side-head area also provides whitespace so the over-all impres-
sion given by the layout is one of openness. The template provides 
several tables, cross-reference formats, and, in general, the same 
collection of paragraph and character formats as BkStyle1. The trim 
size is 7.5 by 9 inches.

Nut & bolts

The paragraph and character formats are virtually identical to 
those of BkStyle1, at least in name and purpose. Note especially the 
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Numbered.intro paragraph you must use before any numbered 
steps to reset the series.

The special Query, Typed-in.para, and Typed-in.text formats from 
BkStyle1 are among the usual formats. You’ll also find the 
Illo+Caption format for use as a way to keep anchored frames with 
their captions on the same page. BkStyle2 includes a special Warn-
ing table format you can use for warnings and other important 
paragraphs you want to emphasize.

The dotted line under the chapter name is on a reference page.

Making it your own

Besides changing fonts to something more interesting than Times 
and Helvetica, you could also change the spot color used. We used a 
simple default bullet symbol you might want to change. Just rede-
fine the BulletSymbol character format to reflect a dingbat font you 
have installed. Then replace the \b with the appropriate character in 
the Autonumber Format box of the Bulleted format’s Numbering 
property in the Paragraph Designer.

Note the use of an anchored frame for an icon or graphic in the 
side-head area on page 4 of the BkStyle2 template. You can use this 
technique to emphasize a tip or note. Insert an anchored frame at 
the beginning of the paragraph outside the column at the left. The 
FrameMaker clip art collection (accessible through Help > 
Samples & Clip Art) provides many symbols and other graphics 
you can use for this purpose. Copy and paste one into the frame.

You might want to change the default dotted line we used under the 
chapter title. Go to the first reference page (View > Reference 
Pages) and change the characters in the frame called Chapter Dots. 
You may have to open the Paragraph Designer when the insertion 
point is in the dots and change the font (for example, to a dingbat 
font) to use the character you want.

BkStyle1 uses a single color for some formats. If you are not print-
ing in color, make sure you print to a printer that can print colors 
as grayscale or change the color AccentColor to a shade of gray in 
View > Color > Definitions. All the colored text and symbols will 
take on the new hue. This is a good example of the importance of 
generally naming character formats and colors for their function, 
rather than for their type style or hue. This lets you change the 
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underlying definition of the format or color without being forced 
to change the name as well.

Book Style 3

This style combines a one-column format with a more complex 
autonumbering scheme than seen in the first two book style tem-
plates. This template numbers chapters, appendices, tables, and 
illustrations independently. The template also numbers pages in 
the chapter-page format (for example, 3-4 means page four of 
chapter three) which is preferred by some designers or pubs 
departments.

Complex
autonumber

schemes

BkStyle3 offers separate autonumber series for chapters, appendi-
ces, tables, and figures and creates generated lists for tables (LOT) 
and figures (LOF) as well as the TOC. There are five table formats 
already defined and a variety of cross-reference formats. Read 
through the notes in the template itself for details.

Nuts & bolts

Most of the formats are self-explanatory, but note the greater com-
plexity found in the formats. Bulleted lists can contain secondary 
bulleted lists indented from the first level. The Bullet2 format lets 
you insert secondary level bulleted items. Indent1 and Indent2 let 
you add unbulleted paragraphs within a bulleted list that line up 
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with the appropriate bullet level. Similarly, Numbered2 lets you 
insert indented numbered lists within numbered lists formatted 
with Number. Indent1 and Indent2 also work in numbered lists.

Note how the Head1-leftside and zHead-rightside paragraph for-
mats are combined or linked to create a head with a note or explan-
atory text (in a different typestyle and point size!). zHead-rightside 
also combines with Head2-leftside for the same effect.

To add text in the sidehead area of this template, use the SideWords 
paragraph format. To place graphics or icons instead of text, insert 
an anchored frame positioned at the outside of the column on the 
left side rather than a special format.

Special character formats you should note include Code and Sym-
bolFont. Use Code for formatting programming code or text the 
user must type. Use SymbolFont to format characters in the Sym-
bol font for special characters such as pi, arrows, or other mathe-
matical symbols.

The template’s mechanism for dealing with graphics differs from 
the formats used in the previous two book style templates. BkStyle3 
assumes that every graphic in the body column (not in the side-
head area) has a caption. To add a graphic, format a blank para-
graph as IlloCaption (IlloCaptionApp in appendixes), type the cap-
tion, and then immediately import a graphic or insert an anchored 
frame without pressing Return.

Making it your own

Change the BookName variable (Special > Variable) to reflect the 
name of your document. The template uses this variable in footers.

You can change the color used for second-level bullets or numbers 
in the zBulletGray and zAuto#Format character formats.

You may need to change the width of the side-head area depending 
on the point size of your type and how you plan to use this area. If 
you want to insert graphics or longish notes, the current five-pica 
width is probably not enough. To change it, switch to master pages 
(View > Master Pages), and choose Format > Page Layout > Col-
umn Layout. Enter a new value for the amount of room given to 
the side-head area. Then click the Update Entire Flow button. You 
cannot Undo this, so to protect yourself, be sure to Save the file just 
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before you change the space reserved for the side-head area. Then 
you can choose File  > Revert to Saved to “undo” the width change 
if it proves inappropriate.

The chapter-page page numbering scheme used in the template 
must be set for each document in the book file by selecting each 
document in the book window and choosing File > Set Up File. 
Then enter the chapter number and a hyphen in the Prefix box. 

Book Style 4

This template is geared toward laser-printed student guides, tutori-
als, and other types of training or in-class instructional material. 
Many of the formats are designed to provide a great deal of hand-
holding for students using the guide.

Ideal for
training

material and
guides

Every aspect of BkStyle4 aims at providing a feature or format for 
creating a handholding guide through any sort of educational or 
training material. A special Title master page lets each chapter 
begin with a chapter overview so students know exactly what is 
covered in the coming chapter. A custom table format called 
StepTable lets you enter easy-to-understand steps with comments 
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to the side explaining what the student should see or know as they 
go through each step of an exercise. There are also special formats 
for review sections in the popular question-and-answer format.

Nuts & bolts

Heading1 always starts on a new page and is accordingly reserved 
for major divisions in the guide. You’ll use Heading2 for all sub-
heads. Two levels of headings may seem sparse, but it’s recom-
mended for training material in order to keep the student from 
getting lost in a complex multi-level labyrinth of headings. Besides 
the omnipresent Body format, your chief formatting tool will be 
the StepTable (Table > Insert Table). This table, for use in exercises 
involving numbered steps, lets you enter a caption explaining the 
current exercise, each step of the exercise (Do this), and any explan-
atory notes or comments (Comments).

A StandardTable lets you organize material in columns (for exam-
ple, keyboard shortcuts and what they do; key words or terms and 
what they mean in the context of the material being studied).

A SideNote format lets you put instructional signposts to the left of 
paragraphs and the Indent format indents a paragraph on both the 
left and right for special emphasis. The two formats Q’s and A’s let 
you format review questions and answers in the popular FAQ style 
for use at the end of a chapter. Several character formats let you for-
mat words as Emphasis, Bold, Code, Small Caps, and Underline.

Making it your own

You might want to create a format for paragraphs containing an 
anchored frame. A guide for a word processing application might 
need screen dumps to illustrate exercises. See BkStyle1 or 
BookStyle2 for ideas on how to do this. You could simple copy an 
anchored frame paragraph from one of those two templates into 
BkStyle4. Then click in the pasted format and then click Apply in 
the Paragraph Designer. When prompted, store in the catalog.

Times and Helvetica work well in laser-printed manuals, but you 
may want to change to something snazzier.

Remember that the chapter-page page numbering scheme used in 
the template must be set for each document in the book file by 
selecting each document in the book window and choosing File > 
Template Pack 1: Books and Manuals 9



Set Up File. Then enter the chapter number and a hyphen in the 
Prefix box. Unfortunately, there is no built-in way to automate this 
process (at least it only has to be done once).

Book Style 5

BkStyle5 is identical to BkStyle2 with one notable addition: run-
ning thumb tabs on recto pages. The template illustrates two types 
of running thumb tabs you might want to use (text runs sideways 
and text is rightside up).

Creating
running

thumb tabs

Running thumb tabs provide users with a way to rapidly find a 
desired section in a long book simply by flipping through it. The 
thumb tabs appear only on rectos, since those are the only pages 
normally seen when you flip through pages. The two examples in 
this template should give you a basic idea how to create running 
thumb tabs in other templates.

Nuts & bolts

Read the entry for BkStyle2 and the notes in the BkStyle2 template 
itself for details on the other features and formats used in BkStyle5.

The mechanism for setting up running thumb tabs confounds 
many users, but it’s actually fairly simple. You create the areas 
where you want the thumb tabs to appear on the appropriate mas-
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ter page — the Right or recto. Note in this example that we drew 
out a text frame over a tinted area that bleeds off the edge of the 
recto. You insert a Running H/F variable (use the Running H/F 3 
variable since it’s set up to look for <$marker1> marker text by 
default) in the text frame and format it (including rotating it for 
sideways text). The underlying variable definition is, as mentioned, 
<$marker1>. Choose the Header/Footer $1 marker and type the 
text you want to appear in the thumbtab. When you want the 
thumbtab to have new text (because the topic has changed), insert 
another Header/Footer $1 marker and change the text.

t Note that in our example template we actually have set up two 
separate running thumb tabs. That’s why you also find a Header/Footer 
$2 and <$marker2> combo.

The change to new text in the thumb tab is not automatic. You have 
to force the change by placing a new marker each time. Once the 
markers are in place, however, the updating is automatic.

Making it your own

Besides the customization suggested in the BkStyle2 entry (differ-
ent fonts, graphics, and so on), you should play around with differ-
ent graphic and text treatments of the running thumbtab area on 
the Right master page. Using FrameMaker’s native draw tools to 
create graphic elements for this area will help keep your file size 
down and doesn’t involve additional programs or expenses.

To make the marker text creep down the running thumbtab area, 
type em dashes or em spaces in the marker text box (\m or \sm) 
before the text when you insert the Header/Footer $1 marker. Add 
additional spaces or dashes for each subsequent thumbtab to make 
it creep further down the running thumbtab area. If you have a lot 
of thumb tabs (A–Z, for example), you’ll have to experiment to get 
the spacing right and then reset (perhaps at “M”) back to the top of 
the page.

If the thumb tabs seem too intrusive or make the page busy or clut-
tered, do away with the tinted background approach we illustrated 
and try tinting the thumbtabs’ text to some shade of gray instead. 
That can help minimize the thumbtabs’ impact on the page, but 
also adds “color” and visual interest to an otherwise black and 
Template Pack 1: Books and Manuals 11



white presentation. In addition, the thumb tabs remain easy to spot 
as the user flips through looking for a specific section.

Book Style 6

BkStyle6 provides an ideal layout for the smallish pamphlets or 
mini-manuals that often accompany TVs, microwaves, VCRs, and 
other consumer products. Use it for any product that requires 
heavily illustrated step-by-step instructions.

Step-by-step
manual

optimized
for HTML

This devilishly simple template uses anchored frames to enclose the 
text and illustrations of each step. That makes export to HTML a 
snap since everything in the anchored frame becomes a single GIF 
(or JPEG) graphic during the conversion. It’s a great way to make 
sure a highly graphical layout makes it through HTML conversion 
intact. The on-screen appearance in a browser is excellent.

Nuts & bolts

Each step of the procedure described in the manual is enclosed in a 
separate anchored frame attached to a blank paragraph formatted 
with the Figure paragraph format. Within each anchored frame sits 
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a text frame with example instructions and graphics. Note that the 
Remote paragraph format is used for special text in the line draw-
ings of the remote control we used as an example. You may find no 
use for it or may want to rename it.

Making it your own

Replace the intro paragraphs and title with your own material.

Replace the sample steps and graphics with your own information. 
Note that the anchored frames will not resize automatically if you 
add more steps or larger graphics than we used. You will need to 
resize the anchored frames on an as-needed basis. This is a nui-
sance, but illustrates an important point about documents you 
intend to use both in print and for on-line use: You may need to 
make compromises in the way you’re used to working with 
FrameMaker. HTML is still a fairly limiting layout environment 
and it may prevent you from using FrameMaker in the most effi-
cient way. The use of anchored frames to encapsulate complex lay-
outs for conversion to HTML is a technique you’ll find invaluable, 
even if it involves some compromises.

Note that we did all the illustrations with FrameMaker’s own draw-
ing tools. This insures portability across platforms and helps keep 
file sizes down since FrameMaker-created artwork tends to be 
smaller than imported graphics. Use the built-in drawing environ-
ment whenever possible.
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Book Style 7

This template draws upon the older (pre-version 5.5) Frame Tech-
nology documentation look, but updates it to make it simpler to 
use. Still present are the chapter-level folios and the running head-
ers that automatically pick up the heads. Removed from the origi-
nal Frame Technology design are the chapter introductions, which 
used a larger point size and special headings. This simplifies the 
design and the implementation.

Alternative
to use of

side-head
feature

One striking fact about this template is that although it looks like it 
contains a side-head area, it in fact does not use the side-head 
mechanism. Instead, it cleverly uses paragraph indents. This makes 
it easy to outdent the numbers and bullets, which would have been 
trickier to do had the template been set up to use true side heads.

Also retained are the easy-to-spot outdented “task heads” (they are 
meant to introduce a task and so usually begin with an infinitive 
construction, “to do x”). The outdented heads are actually 
Heading2s. The Heading1 in this template is the all-caps and col-
ored heads. Unlike the old Frame books, we’ve added a rule to the 
Heading1s to make them more prominent. The BkStyle7 folder 
contains templates for a chapter, TOC, appendix, and an index.
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Nuts & bolts

The formats used in the template are largely self-explanatory, but 
note the following. AnchoredFrame is used to format a blank para-
graph to which a frame is anchored (for illustrations). There are 
three levels of headings, a special format for callouts, and the usual 
Bullet and Numbered formats. The Numbered-single format is for 
a procedure that consists of a single step.

The UserType character format simulates what a user types or what 
a program might display.

The DashLineTable format is the main table you should use in this 
template. You’ll find a sample sidebar among the chapter template’s 
reference pages. Copy and paste it into an anchored frame defined 
as Floating and anchored At Bottom of Column.

The template has a wide variety of cross-reference formats pre-
defined along with three variables for inserting a manual draft ver-
sion number, a product name, and the name of the document.

Making it your own

You’ll need to enter new definitions for the three variables included 
in the chapter template (DraftVersion, ProductName, ThisMan-
ual). Beyond that, explore other fonts and the colors used for 
Heading1 and various graphic accents throughout the document.
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Book Style 8

The BkStyle8 folder contains the template collection used to format 
the various documents that make up the Adobe FrameMaker Tem-
plate Series. The version that is part of this template collection is 
organized for formatting a printed book. BkStyle8 provides tem-
plates for a chapter, TOC, and index tied together by a book file.

White space
and

simplicity

BkStyle8 uses a lot of white space, color/graphic accents, and a sim-
ple heading structure to make the document easy-to-read and nav-
igate. It’s the only template collection that uses fonts other than 
Times and Helvetica (Minion and Frutiger, Bundesbahn Pi 2 and 3) 
since we wanted it to be as true to what we used as possible. This 
does mean that you will see a “missing font” alert when you open 
this template — assuming that you do not have the fonts installed.

Nuts & bolts

The formats need little explanation, but note that BkStyle8 uses the 
NumberIntro format before each numbered list formatted with 
Numbered. There are separate formats for chapter and appendix 
titles. Use the GraphicAnchor format to format a blank paragraph 
for anchored frames containing your document’s illustrations. The 
character formats, except for Bold and Emphasis, are used by para-
graph formats and you’ll probably never have to deal with them.
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Making it your own

If you don’t have Minion, Frutiger, and the Bundesbahn Pi fonts, 
you’ll need to change some format definitions. The Pi2 format cur-
rently uses Bundesbahn Pi 2 and is itself used only in Tip and Bul-
leted. The Pi3 format uses Bundesbahn Pi 3 and is used by Note. 
Simply redefine Pi2 and Pi3 to point to a different pi or dingbat 
font and enter the desired character in the Autonumber format box 
of the Numbering property for the appropriate paragraph format.

If you’re not printing to color, you should probably change Accent-
Color to a shade of gray (20-30%). The current color, at least on a 
laser printer, prints out pretty dark.
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Book International

BkIntl is a single template for simple, unfolded pamphlets that 
present the same information in multiple languages. The template 
uses A4 paper and centimeters as the default unit of measurement.

Nuts & bolts

The template uses a minimum of formats since the layout is simple 
and information needs to be presented in small spaces as efficiently 
as possible. The most distinctive aspect of this template is its use of 
three unconnected text flows — one for each language. There are 
also two basic tables in the template: ShadedTable and LinedTable.

Spell-checking a multilingual document can be a chore. Here is one 
approach you might try:

1 Place the insertion point at the start of the first flow (English), 
and spell-check as usual. FrameMaker goes through the first 
flow first and then continues at the beginning of the second 
flow (French).
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2 When FrameMaker reaches the first French word, it will see it 
as an error. At that point, stop spell-checking.

3 Open the Paragraph Designer and display the Default Font 
properties.

4 Choose Set Window to As Is from the Commands pop-up 
menu, and then choose Francais from the Language pop-up 
menu (If Francais is not in the list, you don’t have the French 
dictionary installed.)

5 Choose Global Update Options from the Commands pop-up 
menu, click Default Font Properties Only and then click All 
Paragraphs and Catalog Entries. Click Update. This changes the 
Language property (and only that property) for all paragraphs 
in the document to Francais.

6 Now continue the spell-check of the French flow.

7 Repeat this process for the German flow.

8 Return all paragraphs to English if you want, or you can keep 
them set to Deutsch and then start with German the next time 
you want to spell-check the file.

That’s a lot of steps, but once you get in the groove, the process goes 
pretty fast.

The template does not export well to HTML and should not be 
used if HTML conversion is a requirement.

Making it your own

If your pamphlet’s languages are not English, French, and German, 
go to the Master Pages and change the text.

The dashed lines separating the languages on each page are back-
ground graphics on the template’s master page. To change their 
appearance, switch to View > Master Pages.

If you have more than three languages, you could add text flows on 
the master page and add background labels and graphics as needed.
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